Sun Aug 31 05:56:02 JST 2014

自分に起きた問題と、 解決までの道筋を丁寧に文字にすることは大変で、 だから、 いざ自分が困ってぐぐっても有益な情報がなかなかなかなかなか みつからないけど 要点だけ箇条書きで。

debian 7.6 をいれた。 apt のレポジトリ、パッケージという言い方がしてあったけど、 Ubuntuなんかと比べると極端に少ない。 本当に自由なソフトウェアに制限してるというのは知ってたけども。

デフォルトの /etc/apt/source.list を再現してのせる。

# 

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 xfce-CD Binary-1 20140712-14:09]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 xfce-CD Binary-1 20140712-14:09]/ wheezy main

deb http://ftp.jp.debian.org/debian/ wheezy main
deb-src http://ftp.jp.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.jp.debian.org/debian/ wheezy-updates main
deb-src http://ftp.jp.debian.org/debian/ wheezy-updates main

実質3つ。 私は次の2つを追加した。(ふたつ目は追加しないほうがよかった)

# for i3
deb http://http.debian.net/debian wheezy-backports main

# i want youtube-dl
deb http://ftp.jp.debian.org/debian sid main 

このふたつ目の sid が 「不安定版ディストリビューション」とも呼ばれるもので、 こっからインストールされるソフトウェアが何が起きるかわかったものじゃなかった。

日本語入力問題

ibus ibus-mozc

この2つだけを、apt-get install すればいいだけである。

$ ibus-daemon --version
ibus-daemon - Version 1.4.1

これは問題ない。解決した今、使ってるんだから。 そしてこれは wheezy パッケージから入れた。

sid パッケージを追加してると、 デフォルトで ibus 1.5.8 が現時点で入るようだ。 これはまだ使えない。

私は結局、sidパッケージと、ついでにwheezy-backportsを無効にして、 (つまり /etc/apt/source.list から行を消して apt-get update して) ibus を入れなおすことで解決したけど、

apt-get install -t wheezy ibus ibus-mozc

でもよかったかもしれない。 これは試してない。